Отладка шаблонов ограничений

Публикация № 1216232

Разработка - Инструментарий разработчика - Прочие инструменты разработчика

Обработка предназначена для получения результирующего текста ограничений доступа при использовании шаблона ограничений доступа, с учетом фактических параметров, параметров сеанса и функциональных опций.

При использовании конфигураций использующих ограничений доступа к данным на уровне записей (RLS), часто возникает потребность составить результирующий запрос к таблице, с учетом всех установленных для пользователя ограничений.  В конфигурациях на базе библиотеки стандартных подсистем (БСП) такие ограничения устанавливаются с помощью достаточно сложных шаблонов ограничений. К сожалению платформа не имеет встроенных средств для получения итогового текста ограничений из шаблона, с учетом фактических параметров, параметров сеанса и функциональных опций. Для решения этой проблемы предназначена данная обработка.

В обработке указываются следующие параметры.

Имя текущей таблицы - имя исследуемой таблицы в формате, возвращаемом функцией ПолноеИмя() для объекта метаданных, например Справочник.Номенклатура. Необходимо для правильной работы ограничений, использующих параметры #ТекущаяТаблица и #ИмяТекущейТаблицы

Имя текущего права доступа - Чтение,Добавление,Изменение,Удаление. Необходимо для правильной работы шаблонов ограничений, использующих параметр #ИмяТекущегоПраваДоступа

Ограничение доступа - текст применения шаблона ограничений из текста ограничений доступа, например #Шаблон("Параметр1", "Параметр2")

Определение шаблона ограничений - текст, указанный в поле Наименование шаблона ограничений. Имеет смысл указывать, если для шаблона определены параметры

Шаблон ограничений - текст шаблона ограничений, вызов которого указан в поле Ограничение доступа.

Т.к. шаблона ограничений доступа может зависеть от параметров сеанса, зависимых от авторизованного пользователя, рекомендуется вызывать обработку под тем пользователем, для которого будет использоваться данное ограничение доступа.

После нажатия на кнопку "Подставить", в поле "Результат" будет выведен результирующих текст ограничений доступа, а в таблице ниже - значения параметров, используемых в результирующем тексте ограничений доступа. В дальнейшем эту информацию можно использовать для отладки запроса в консоли запросов.

Минимальная версия платформы: 8.3.6.

Скачать файлы

Наименование Файл Версия Размер
Отладка шаблонов ограничений:

.epf 10,69Kb
39
.epf 1.0.3.2 10,69Kb 39 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. maxx 920 30.03.20 12:52 Сейчас в теме
Попробовал запустить, вот ошибку выдаёт
Прикрепленные файлы:
3. vadim1980 109 22.05.20 21:17 Сейчас в теме
(1) Версия обработки 1.0.3.1 вычисляет только используемые в шаблоне параметры сеанса и функциональные опции
2. vadim1980 109 30.03.20 13:11 Сейчас в теме
(1) При запуске, обработка вычисляет все значения параметров сеанса. Скорее всего для одного из параметров у вас не определена инициализация. Для какого именно, можно понять с помощью отладки из Конфигуратора
4. 9539356 29.12.20 09:07 Сейчас в теме
Исправлена ошибка:
Если ЧастьУсловия.Свойство("Условие") Тогда
Выражение = ЧастьУсловия.Условие;
Для Каждого ЭлементСоответствия Из ЗначенияПараметров Цикл
// +++ Ошибка
// Имеется: ЗначенияПараметров["Соответствие"]["ОграничиватьДоступНаУровнеЗаписей"]
// Ожидается: ЗначенияПараметров["_ЗначенияПараметров_"]["ОграничиватьДоступНаУровнеЗаписей"]
Если ЭлементСоответствия.Ключ = "_ЗначенияПараметров_" Тогда
Продолжить;
КонецЕсли;
// ---
Выражение = СтрЗаменить(Выражение, ЭлементСоответствия.Ключ, ЭлементСоответствия.Значение);
КонецЦикла;

РезультатВыражения = Вычислить(СтрЗаменить(Выражение, Символы.ПС, " "));
Если РезультатВыражения Тогда
ИстиннаяЧастьУсловия = ЧастьУсловия;
Прервать;
КонецЕсли;
Иначе
ИстиннаяЧастьУсловия = ЧастьУсловия;
Прервать;
КонецЕсли;
Показать
5. vadim1980 109 29.12.20 10:47 Сейчас в теме
(4) Вы проверяли на последней версии?
6. 9539356 29.12.20 12:37 Сейчас в теме
(5) Обработка была скачана с Инфостарта 04.11.2020 07:48:22
7. vadim1980 109 29.12.20 14:14 Сейчас в теме
(6) Дата последней версии 14.11.2020
8. 9539356 05.01.21 08:20 Сейчас в теме
(7) Как мне ее скачать повторно? Я первый раз скачал вашу обработку с инфостарта за стартмани.
Оставьте свое сообщение

См. также

Проверка ведения учета (универсальная)

Анализ учета Прочие инструменты разработчика v8 v8::Запросы Россия Абонемент ($m)

Универсальная проверка ведения учета, построенная на запросах. Выполнена в виде расширения, имеет функции подключения к другим информационным базам по технологии внешних соединений и отладчик, поддерживает конструктор запросов. Предназначена для использования как информационно-техническими специалистами, так и для самостоятельного использования конечными пользователями.

2 стартмани

11.08.2020    2521    16    vozhd    2