Добавление функционала прикрепленных файлов без изменения конфигурации

Публикация № 1338383

Разработка - Практика программирования

Прикрепление файлов вложения расширение

Пришло как-то на работе задание организовать прикрепление файлов к справочнику Основные средства. Все бы ничего, да только конфигурация типовая, решил попробовать к БСП, но и при ее использовании необходимо вносить изменения в конфу, крайняя попытка была предложить прикреплять файлы не справочнику, а к документу принятия к учету, но и тут фиаско: наши бухгалтера вставляли данные напрямую в справочник. Решил я эту проблему, написав расширение. В данной статье описан процесс создания. И выложен готовый файл для скачивания.

Решение было протестировано на платформе 1С:Предприятие 8.3 (8.3.18.1208). И так реализовано было все максимально просто: в первую очередь я создал справочник (В предварительно созданном расширении, в которое добавил Справочник основных средств ) для хранения прикрепленных файлов назвал "ПрикрепленныеФайлы" задал три реквизита:

  1. "Файл" с типом ХранилищеЗначения
  2. "Имяфайла" тип Строка
  3.  "ВладелецФайла" тип соосветственно СправочникСсылкаОсоновныеСредства

Далее создал форму справочника с соответствующими полями и кнопками "Сохранить на диск" "Загрузить с диска", а также форму списка. Код формы элемента получился следующий:


&НаКлиенте
Процедура ЗагрузитьСДиска(Команда)
	АдресВХранилище = "";
ВыбранноеИмяФайла = "";
Если ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор) Тогда
Файл = Новый Файл(ВыбранноеИмяФайла);
Имя = Файл.Имя;
СсылкаНаФайлВоВременномХранилище = АдресВХранилище;
Объект.Наименование = Файл.Имя;
Модифицированность = Истина; 
Объект.ИмяФайла = Имя;
КонецЕсли;               
КонецПроцедуры

&НаКлиенте
Процедура СохранитьНаДиск(Команда)
	Если Объект.ИмяФайла = "" Тогда
Предупреждение("У поставщика нет сохраненного в базе договора");
Иначе
СсылкаНаФайлВИБ = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Файл");
ПолучитьФайл(СсылкаНаФайлВИБ, Объект.ИмяФайла);
КонецЕсли;        
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Имя = Объект.ИмяФайла; 
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	// Получить файл из хранилища и поместить его в объект.
Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
ДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
ТекущийОбъект.Файл = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
//ТекущийОбъект.ИмяФайла = ИмяФайлаКонтрагента;
ТекущийОбъект.ИмяФайла = Имя;       
КонецЕсли;       
КонецПроцедуры

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	//Удалить файл из временного хранилища
Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
УдалитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
КонецЕсли;
КонецПроцедуры

На форму элемента  справочника ОС (предварительно поместив ее в расширение)  добавил кнопки "Прикрепить файл" и "Показать файлы"

Коды обработчиков нажатий:


&НаКлиенте
Процедура Вложения_ПоказатьФайлыПосле(Команда)
	ПараметрыФилльтра = Новый Структура;
	Отбор = Новый Структура;
	Отбор.Вставить("ВладелецФайла", Объект.Ссылка);
	ПараметрыФилльтра.Вставить("Отбор", Отбор);	
	ОткрытьФорму("Справочник.ПрикрепленныеФайлы.ФормаСписка",ПараметрыФилльтра);
КонецПроцедуры

&НаКлиенте
Процедура Вложения_ПрикрепитьФайлПосле(Команда)
П = Новый Структура;

П.Вставить("Основание", Объект.Ссылка);

ОткрытьФорму("Справочник.ПрикрепленныеФайлы.Форма.ФормаЭлемента", П);

КонецПроцедуры

На этом все. Вопросы. Критику просьба оставлять в комментариях. Постараюсь отвечать оперативно.

Скачать файлы

Наименование Файл Версия Размер
Добавление функционала прикрепленных файлов без изменения конфигурации:

.cfe 36,17Kb
0
.cfe 36,17Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Рамзес 29 28.12.20 14:55 Сейчас в теме
Пометка на удаление владельца прикрепленных файлов как-нибудь обрабатывается?
2. solutioncp24 101 29.12.20 05:11 Сейчас в теме
здравствуйте, нет не обрабатывается
3. Zhilyakovdr 127 30.12.20 10:26 Сейчас в теме
Добрый день.
1) в частичном снятии в конфигурации запрета на редактирование нет ничего страшного;
2) хранить файлы в хранилище значений не очень хорошо;
3) для использования подсистемы БСП в данных целях придется снять блокировку только с нескольких объектов "Определяемые типы" все остальное делается в расширении.

За попытку использования БСП однозначно "+" )))
п.с. если интересны подробности могу написать мини инструкцию-памятку.
4. solutioncp24 101 30.12.20 12:26 Сейчас в теме
(3)ну напишите интересно, моя задача была сделать полностью без снятия блокировок
Оставьте свое сообщение

См. также

Публикаций не найдено

Попробуйте расширить область поиска, проверьте поисковый запрос и повторите попытку.

Или закажите индивидуальную разработку вашего решения.

Создать заказ на разработку